Analysis and contextual insights are available on OpenCVE Cloud.
No vendor fix or workaround currently provided.
Additional remediation guidance may be available on OpenCVE Cloud.
Tracking
Sign in to view the affected projects.
No advisories yet.
Mon, 02 Nov 2026 22:45:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Description | A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product. | |
| Title | Welcart e-Commerce Plugin paymentESCOTT.main.class.php error_page_message cross site scripting | |
| First Time appeared |
Welcart
Welcart e-commerce Plugin |
|
| Weaknesses | CWE-79 CWE-94 |
|
| CPEs | cpe:2.3:a:welcart:e-commerce_plugin:*:*:*:*:*:*:*:* | |
| Vendors & Products |
Welcart
Welcart e-commerce Plugin |
|
| References |
| |
| Metrics |
cvssV2_0
|
Status: PUBLISHED
Assigner: VulDB
Published:
Updated: 2026-11-02T22:30:20.300Z
Reserved: 2026-11-02T16:59:10.077Z
Link: CVE-2026-120597
No data.
No data.
No data.
OpenCVE Enrichment
No data.